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Changes to WebSphere JMS Front Side Handler drops messages

Troubleshooting


Problem

Configuration changes to the WebSphere JMS Front Side Handler while transactions are flowing might cause messages to be dropped when not using transactionality. The WebSphere JMS Front Side Handler must be referencing a WebSphere JMS Server configuration with transactionality disabled.

Cause

The previously configured WebSphere JMS Front Side Handler might receive the messages meant for the newly configured WebSphere JMS Front Side Handler. When the previous handler instance receives the message, it realizes it should not have received the messages, but does not have the capability to put the messages back on the destination for processing by the new instance.

Resolving The Problem

To prevent this issue, please follow these three steps if the WebSphere JMS Front Side Handler configuration has to be updated:

  1. Disable the WebSphere JMS Server instance referenced by the WebSphere JMS Front Side Handler
  2. Update the WebSphere JMS Front Side Handler configuration
  3. Enable the WebSphere JMS Server instance referenced by the WebSphere JMS Front Side Handler

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Document Information

Modified date:
15 June 2018

UID

swg21671108