IBM Support

samadapter fails to start after migration from TSAMP 3.x to 4.1

Question & Answer


Question

After upgrading Tivoli System Automation for Multiplatform (TSAMP) from v3.x to v4.1, the samadapter fails to start with message " Unable to bind a socket to address"

Cause

The samadapter configuration had not been changed since the upgrade, so the IBM.ServiceIP was still part of the samadapter configuration

Answer

After upgrading TSAMP from 3.x to 4.1 and the new version 4.1 code was activated with "samctrl -m", the new samadapter behavior is also activated. It is no longer required to have a special policy active for samadapter. This means any existing policy for samadapter should be removed.

But if there is an attempt start samadapter immediately after migration, there will likely be a problem. The logfile "/var/ibm/tivoli/common/eez/logs/msgFlatAdapter.log" might contain:

      EEZAdapterMain.isAlreadyRunning Unable to bind a socket to address <ServiceIP> at port 2001. Reason: BindException: Cannot assign requested address

      EEZAdapterMain.run Initialization of the adapter failed

      EEZAdapterMain.main The adapter has been stopped due to a failure, rc=20
      Explanation: The automation adapter stopped because an error occurred. All possible stop delay periods are over. The process stops immediately.
      The return code might be:
      12 if initial contact failed
      13 if the remote contact activity threshold is exceeded
      16 if a plug-in forced termination of the automation adapter
      20 if initialization failed
      24 if an error occurred after initialization was successful
      28 if an unsupported environment is detected
As already stated, the IBM.ServiceIP address for samadapter is no longer required in TSAMP 4.1. To resolve the above problem, open the samadapter configuration GUI, 'cfgsamadapter', click on "Configure". On the tab "Adapter", check the contents of "Automation adapter host" - "Host name or IP address" ... if IBM.ServiceIP address is still there, remove it .

The text field "Host name or IP address" should either contain the local host name or check the checkbox next to the textfield labeled "Use local host name". Click on "Save" and exit.

If you checked the "Use local host name" then replicate settings in the domain. Otherwise configure on the other nodes in the domain directly.

[{"Product":{"code":"SSRM2X","label":"Tivoli System Automation for Multiplatforms"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"4.1","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21670220