IBM Support

Cannot Start Cognos Services - NodeHospital Failure ... DPR-DPR-1035 Dispatcher detected an error

Troubleshooting


Problem

When starting Cognos Services, the user may experience an issue which does not allow them to start the service successfully.

Symptom

Error Messages:

Audit.Other.dispatcher.DISP.pogo pogo com.cognos.p2plb.model.NodeHospital Failure
DPR-DPR-1035 Dispatcher detected an error.

Cause

There are a various different reasons why you may encounter this error. Below are a few reasons for the cause of this issue:

1) Conflicting port numbers
2) Incorrect configuration of the Common Symmetric Key in a distributed environment
3) Incorrect startup of the Cognos components

Resolving The Problem

Below are 3 scenarios which can be used to resolve this issue:

Scenario 1: Conflicting port numbers

Look at all your instances of Cognos Configuration > Environment and ensure the port numbers do not conflict with other components.

E.g. Application Tier Instance
Internal Dispatcher URI = http://[servername]:9300/p2pd/servlet/dispatch

Content Manager Instance
Internal Dispatcher URI = http://[servername]:9300/p2pd/servlet/dispatch

Scenario 2: Incorrect configuration of the Common Symmetric Key in a distributed environment

If you are using a distributed environment, ensure that the 'Store Symmetric Key locally?' variable is set to 'True' for only the Content Manager component.

This option can be found in Cognos Configuration > Security > Cryptography.

This ensure that the all components of Cognos fetches the Common Symmetric Key only from the content manager and that all components are using the same key,

Scenario 3: Incorrect startup of the Cognos components

When trying to start Cognos services using a distributed environment, ensure that the Content Manager component is started up first. This is so that the certificate authority service is available to issue certificates to other computers.

After the Content Manager starts up successfully. you can start up Application Tier component/s.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1;8.4.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21668813