IBM Support

Guardium STAP on Windows collects no traffic from Oracle Database

Troubleshooting


Problem

Infosphere Guardium STAP will fail to collect traffic from an Oracle inspection engine if the port range is set to a single port, like the 1521 default. This applies only to Windows.

Symptom

STAP shows green in System View, but no traffic is collected.

Cause

In Windows, most of the traffic Guardium collects is between the TNS and the SQL client, which can be assigned any port from 1000 - 65535 not between TNS and Oracle on port 1521.

Resolving The Problem

Set the inspection engine's minPort to 1000 and maxPort to 65535 and restart the STAP service.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.0;8.2","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21668667