IBM Support

Unable to view PDF or Tiff images with FileNet Workplace XT

Troubleshooting


Problem

Unable to view PDF or Tiff images with Workplace XT IBM Production Imaging Edition Viewer Pro (PIE) after upgrading from Workplace XT 1.1.5 FP001 to XT 1.1.5 FP002 Getting error message in the PIE Viewer: Error:ji.net.jiServerException: Server did not respond with OK Error: Server not available. Please contact your system administrator.

Symptom

  • The streamer page http://<XTserver:port>/WorkplaceXT/iviewpro/streamer returns with below error:

  • Error: iviewerpro.streamer servlet startup error: Server error.
  • Images viewed fine if you disable the streamer for PDF and Tiff image.

  • To disable the streamer for certain images type, update the content_redir.properties file in the <Workplace XT install folder>/config/WebClient as followed by setting streamer= false then restart the application server.

    application/pdf=/iviewpro/WcmJavaViewer.jsp?id={OBJECT_ID}&streamer=false&{JSP_QUERY_STRING}
    image/tiff=/iviewpro/WcmJavaViewer.jsp?id={OBJECT_ID}&streamer=false&{JSP_QUERY_STRING}

  • enable streamer trace shows the below messages and errors in the Streamer.log:

    iviewpro.streamer> WebContainer : 5 12 Mar 2014, 10:40:43, PDT (000000909/000000000): resource location = wsjar:file:/C:/Program Files/IBM/WebSphere/AppServer/profiles/AppSrv01/installedApps/CellName/WorkplaceXT.ear/web_client.war/WEB-INF/lib/IBMv31update_server/jiserver.jar!/jiserver.v1

  • ..............
    iviewpro.streamer> WebContainer : 5 12 Mar 2014, 10:40:50, PDT (000008805/000000000): Installed version is now 1.1.210
    .............
    iviewpro.streamer> WebContainer : 5 12 Mar 2014, 10:40:52, PDT (000010749/000000000): Saving message file as C:\Program Files\IBM\WebSphere\AppServer\profiles\AppSrv01\temp\cmp8Node01\aeserver \WorkplaceXT\web_client.war\v1files\viewone\rep\11210.rep/en.dat iviewpro.streamer> WebContainer : 5 12 Mar 2014, 10:40:52, PDT (000010759/000000010): Saved message file. iviewpro.streamer> WebContainer : 5 12 Mar 2014, 10:40:52, PDT (000010759/000000000): VersionPartError: jiserver-resources-win32.jar: Problem occurred while attempting to check version: v4 ji.server.g: jiserver-resources-win32.jar: Problem occurred while attempting to check version: v4
    at ji.server.util.f.a(Unknown Source) at ji.streamer.servlet.p.init(Unknown Source)
    ..............
    at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905) at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
    iviewpro.streamer> WebContainer : 5 12 Mar 2014, 10:40:53, PDT (000011225/000000466): Sending error Error: Server not available. Please contact your system administrator.

Step to enable streamer logging:

Add the below parameters in the iviewpro.streamer.properties file and restart the application server.

    tracenet=true
    trace=true
    tracestreamer=true
    traceexception=true


    Unless defaults were changed, the streamer configuration file should be found in: <install-directory>./FileNet/config/ImageViewerPro\iviewpro.streamer.properties.


    Unless defaults were changed, the log should be written here:
    <install-directory>/IBM/FileNet/config/ImageViewerPro/streamer.log

Cause

After upgrading to Workplace XT 1.1.5 fix pack 002 from XT Workplace 1.1.5 Fix Pack 001 the Viewer and streamer were loading the older jar files from the IBMv31update_server backup directory listed below instead of from the <Application server deployed directory>/WorkplaceXT.ear/web_client.war/Web-INF/lib directory. The version of the PIE Viewer is 1.1.210 instead of the correct version 4.0.26. PIE Viewer 1.1.210 comes with XT 1.1.5 FP001 and PIE Viewer version 4.0.26 come with XT 1.1.5 FP002. With the older version of the jar files loaded, the streamer is unable to start.


<Websphere install path>/profiles/AppSrv01/installedApps/cellName
/WorkplaceXT.ear/web_client.war/WEB-INF/lib/IBMv31update_server/jiserver.jar!/jiserver.v1

Resolving The Problem

Steps to resolve issue:

  1. Stop the application server then backup and remove IBMv31update_server folder from the WebSphere deployment in ./WorkplaceXT.ear/web_client_war/WEB-INF/lib/. You can also remove it from the Workplace XT installation directory, recreate the web_client.war and web_client.ear then redeploy Workplace XT.

  2. Clear the WebSphere cache from the temp and wstemp folder, Java cache, browser cache and local user cache.

  3. Restarted the application server.

  4. Verify from the streamer.log that it now loads the correct version of the PIE Viewer.

  5. Test to ensure the streamer URL returns fine.

[{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Workplace XT","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"1.1.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21668211