IBM Support

How to repair broken Change Management links in CMI

Question & Answer


Question

How do you repair broken change management links in IBM Rational ClearCase after a failure occurs?

Cause

Occasionally, the process of establishing a link with the change management provider database may fail to complete, due to network instability, user error, or other reason. This document explains how to repair the link(s) should that occur.

Answer

Logs:

If CMI encounters an error while creating a link to a change management provider, recovery information will be written to a repair log file in the ClearCase log directory, if repair logging is enabled. The file is called cmi_repair_log.

To enable repair logging, add the line cmiRepairLogEnabled=true to the CMI configuration file located in the config directory of the ClearCase installation.

You may receive a message similar to the following:

cleartool: Error: Unable to perform one or more Change Management actions.

Examine the repair log to see if the attempted operation has been captured.



Procedure to repair:

To repair the link, use the utility clmutil:


> clmutil cmi_repair [-verbose] [-preview] [-migrate] [-repair_file pathname]
  • Do not use the -migrate option for this purpose.
  • The -verbose option displays additional diagnostic information.
  • The -preview option displays what would have been repaired, but does not actually perform the repairs.
If desired, you may copy the file cmi_repair_log to another location before attempting the repair.
In this case, specify the -repair_file option and enter the pathname of the copied file.
Note: Without the -repair_file option, clmutil will attempt to rename the cmi_repair_log file to cmi_repair_log.backup so that the original file may continue to collect new errors as they occur. The backup file will then be used as the source for repair operations.

You must be set to a view when you run clmutil cmi_repair, and (except when using -preview) you must be root (on UNIX or Linux) or a member of the Administrator group and the ClearCase group on Windows.

Before creating the task associations, you must use the cmiregister command to store the necessary credentials for CMI. As root or Privileged User run

> cmiregister add -cq -name <provider-name> -userdb <database-name> -dbset  dbset-name> -username <username> [-password <password>]

Supply a password only if one is needed by your ClearQuest installation.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: IBM","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.0.0.10;8.0.1.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21667525