IBM Support

An invalid or expired OAuth token error may occur during an Enterprise Dependency Build in IBM Rational Team Concert 4.0.6

Flash (Alert)


Abstract

This Alert is meant to inform users about an issue which can cause an enterprise dependency build to fail when using IBM Rational Team Concert (RTC) version 4.0.6.

Content

At the beginning of an enterprise dependency build request, a source code data update scan is performed on the build stream. If the stream contains a large number of new or modified files, the build may fail due to an expired OAuth token.

Symptoms:
The enterprise dependency build will fail. The build log will contain the following error message: CRJZS0034E The OAuth token is not valid or expired.

Defect:
This issue was identified as product defect APAR PI13626. Review the following work item on Jazz.net for further details: RTC EE dependency build fails with an invalid or expired OAuth token exception (306271)

Workaround:
None

Recommendation:
If you have upgraded to RTC 4.0.6, contact IBM Rational Support and reference APAR PI13626 or Jazz Defect Work Item 306271 to request a testfix for this issue.

Document information

More support for: Rational Team Concert
Build

Software version: 4.0.6

Operating system(s): IBM i, z/OS

Reference #: 1667333

Modified date: 14 March 2014


Translate this page: