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"Error repairing connection ... CM-REQ-4342 An error occurred with the client" when trying to click 'Repair' inside Controller Configuration

Troubleshooting


Problem

Administrator opens Controller Configuration, and opens 'Report Server' section. Administrator clicks green 'tick' box, and then clicks 'Repair' button. An error appears.

Symptom


Error repairing connection. Please verify that the target URI is valid and that IBM Cognos is online.

Error Details:
CM-REQ-4342 An error occurred with the client.

Cause

There are many different possible causes for the generic "Error repairing connection" message.

  • See separate IBM Technote #1382320 for more examples.

In addition, there are several possible causes for the 'CM-REQ-4342 An error occurred with the client' error.
  • TIP: For more examples, see separate IBM Technote #1696820.

This Technote specifically relates to the scenario where the cause is that the SQL login (e.g. 'fastnet') has a password which contains an invalid character (for example the less than symbol '<').

Resolving The Problem

Modify the SQL login's password to have standard alphanumeric characters.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21665532