IBM Support

A new TRIRIGA install Application shutdowns when user logs on

Troubleshooting


Problem

After performing a new install find when user logs onto TRIRIGA they are logged off and the application server is shutdown. The cause was a bad classpath (ie typo).

Symptom

In the Weblogic log:

ClassNotFoundException:
org.antlr.stringtemplate.language.ChunkToken

Server.log:

2014-02-14 14:20:59,570 ERROR [com.tririga.architecture.security.dataaccess.AuthenticationDAO](Thread-6) EXCEPTION
java.lang.IllegalStateException: The HeartbeatThread is not running.
at com.tririga.platform.heartbeat.HeartbeatManagerImpl.interruptHeartbeatThread(HeartbeatManagerImpl.java:41)

Cause

Typo in the classpath causes the class exception at startup of WebLogics.

Environment

Problem reported on WebLogics but likely a common problem.

Diagnosing The Problem

Check the TRIRIGA server.log and the application server logs.

Check the ant.log for installation exceptions.

Resolving The Problem

Correct any typo's in the classpath.

The TRIRIGA folder has a text file that contains the classpath.

C:\TRIRIGA\classpath.txt

So in this example:

The issue was that the WebLogic server CLASSPATH, modified during the TRIRIGA installation.
Had antlr2.7.7.jar instead of antlr-2.7.7.jar. There was a missing dash before the digit 2.

[{"Product":{"code":"SSHEB3","label":"IBM TRIRIGA Application Platform"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM TRIRIGA Application Platform","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent;3.3.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21665237