Troubleshooting
Problem
Attempts to Sync users in IBM Rational Team Concert(RTC) results in the error 'CRJAZ1380E Error synchronizing users.'
Symptom
Attempts to create a user or import them in RTC results in the following message:
Problems were encountered importing some of the users:
The new user could not be created because a user with the user id already exists.
While running the command:
repotools.ccm.bat -syncUsers results in following error:
CRJAZ1380E Error synchronizing users.
Cause
The mapping files have become corrupt during the Jazz Team Server(JTS)/Rational Team Concert upgrade from the previous version
Resolving The Problem
There is a way to clear the mapping file from JTS to Change and Configuration Management (CCM) :
- Shut down the JTS server.
- Bring up a command prompt and cd to \\<<JazzTeamServer>>\server location
- Create an empty text file and name it users.txt
- Issue this command:
repotools-ccm -migration_importUserMapping fromMappingFile=users.txt
- Restart the server.
Wait for a couple minutes until the internal ContributorSynchronizingTask runs.
Then compare the active users under JTS and its applications to see if the numbers match.
Product Synonym
Rational Team Concert
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Document Information
Modified date:
16 June 2018
UID
swg21663881