IBM Support

Unable to synchronize some LDAP Jazz Users with Rational Team Concert

Troubleshooting


Problem

Attempts to Sync users in IBM Rational Team Concert(RTC) results in the error 'CRJAZ1380E Error synchronizing users.'

Symptom

Attempts to create a user or import them in RTC results in the following message:

Problems were encountered importing some of the users:

The new user could not be created because a user with the user id already exists.

While running the command:

repotools.ccm.bat -syncUsers results in following error:

CRJAZ1380E Error synchronizing users.

Cause

The mapping files have become corrupt during the Jazz Team Server(JTS)/Rational Team Concert upgrade from the previous version

Resolving The Problem

There is a way to clear the mapping file from JTS to Change and Configuration Management (CCM) :

  1. Shut down the JTS server.


  2. Bring up a command prompt and cd to \\<<JazzTeamServer>>\server location


  3. Create an empty text file and name it users.txt

  4. Issue this command:

    repotools-ccm -migration_importUserMapping fromMappingFile=users.txt

  5. Restart the server.

Wait for a couple minutes until the internal ContributorSynchronizingTask runs.
Then compare the active users under JTS and its applications to see if the numbers match.

[{"Product":{"code":"SSUC3U","label":"IBM Engineering Workflow Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Team Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0;4.0.0.1;4.0.0.2;4.0.1;4.0.2;4.0.3","Edition":"Standard","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Product Synonym

Rational Team Concert

Document Information

Modified date:
16 June 2018

UID

swg21663881