IBM Support

Unable to start tm1 server "System error 1067 has occured"

Troubleshooting


Problem

Starting a tm1 server via cognos configuration or tm1 application method result is "System error 1067 has occured".

Symptom

Windows Event viewer under application:

tm1sd.error:3

Data directory not specified. Aborting server start up.

Cause

Drive not mapped to be full path of to the directory

Resolving The Problem

You must specify the location of where the tm1s.cfg exists not just the letter of the mapped drive

When mapping a hard drive and you receive the above error please re-mapped the drive to the full path of the data directory.

Example:

data directory located at z:/tm1/data within the tm1s.cfg file.

Mapping the drive the the following path may fail. UNC path: \\machine.com (Z:).

Mapping the drive to the full path has resolved the 1067 error: \\machine.com\tm1\data\

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21663680