Troubleshooting
Problem
Excessive lock duration during FileNet CM object store addon creation may result in SQL lock timeouts that will cause addon installation to fail.
Symptom
DB transactions are rolled back due to SQL timeout.
Cause
When multiple DB2 pureScale members are active during FileNet CM addon creation, excessive SQL locking may occur, resulting in a potential lock timeout. This can result in transactions being rolled back, thereby resulting in the addon installation failing.
Diagnosing The Problem
Examine both the P8 error log and the DB2 diagnostic logs for each active member for lock timeout error messages similar to the following:
DB2 (db2diag.log):
FUNCTION: DB2 UDB, lock manager, sqlplWaitOnWP, probe:999
MESSAGE : ZRC=0x80100044=-2146435004=SQLP_LTIMEOUT
"LockTimeOut - tran rollback Reason code 68
P8 (p8_server_error.log):
com.filenet.api.exception.EngineRuntimeException: FNRCE0019E: E_DEADLOCK_ERROR: The operation could not be completed due to a deadlock error. A retry might be appropriate.
Caused by: com.ibm.db2.jcc.am.SqlTransactionRollbackException: DB2 SQL Error: SQLCODE=-911, SQLSTATE=40001, SQLERRMC=68, DRIVER=4.15.82
Note: The SQLERRMC=68 suggests that the root cause is a SQL lock timeout even though the P8 error message and SQLCODE suggest a deadlock occurred.
Resolving The Problem
The lock timeouts can be avoided by only having a single DB2 pureScale member active during FileNet CM addon installation. Once addon installation has completed successfully, the other members can be brought back online.
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Document Information
Modified date:
17 June 2018
UID
swg21663414