IBM Support

"The request failed with HTTP status 401: Unauthorized" when launching Controller caused by no valid provider enabled

Troubleshooting


Problem

User launches Controller. User receives error.

Symptom


An error occurred while trying to access the server

Details:
The request failed with HTTP status 401: Unauthorized

Cause

There are other potential causes for this error.

  • See separate IBM Technote 2004398 for more examples.

This Technote specifically relates to the scenario where the cause is that the Controller application server's website (IIS) has been incorrectly configured to have no enabled providers:

Environment

Controller application server based on Windows 2008 R2, with its webserver (IIS) configured to use Windows Authentication.

Resolving The Problem

Enable the relevant provider(s) on the Controller application server.

Steps:
1. Logon to the Controller application server as a Windows administrator
2. Launch IIS Manager
3. Locate the part of the website (typically the 'Default Web Site') where the Windows authentication has been enabled from.
4. Double-click on the section 'Authentication'
5. Highlight "Windows Authentication"
6. Click "Providers"
7. Modify it so that it contains the correct/relevant providers.

  • TIP: By default, this is as follows:

Negotiate
NTLM

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21662830