Troubleshooting
Problem
A Tivoli Storage Manager server instance fails to start due to a tablespace in "Roll forward pending" state.
Cause
A hardware or host issue causing a tablespace into "Roll forward pending" state
Environment
Tivoli Storage Manager Server V6 and V7
Diagnosing The Problem
Logon with the Tivoli Storage Manager server instance userid and run the "db2 list tablespaces show detail
" command. The output shows a Tablespace in "Roll forward pending" state. For example :
Tablespace ID = 2
Name = USERSPACE1
Type = Database managed space
Contents = All permanent data. Large table space.
State = 0x0080
Detailed explanation:
Roll forward pending
In this example, the USERSPACE1 tablespace is in "Roll forward pending" state.
Resolving The Problem
Assuming the transaction logs are complete and healthy, the USERSPACE1 tablespace can be rolled back to normal using the following command :
db2 "rollforward database tsmdb1 to end of logs and complete tablespace (userspace1) online"
Notes :
- Specify the correct tablespace name based on the above command. The tablespace name is listed in the "db2 list tablespaces show detail
" command output.
- You can use the "db2 list utilities show detail
" command to monitor the rollforward progress.
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Document Information
Modified date:
17 June 2018
UID
swg21662775