IBM Support

Web GUI 7.4 FP01 install fails in windows

Troubleshooting


Problem

WebGUI 7.4.0 FP 01 installation failing with error : SEVERE : Aborting installer: ${IAGLOBAL_INVALID_TIP22_LOCATION_BASED_NOT_FOUND}

Cause

TIP 2.2 base was not found by the installer:
Windows is not case sensitive, so uses the %TIPHOME% variable as given in the Response.txt but when compared with the %TIPHOME% path as stored in the DE repository it be seen as different.

Diagnosing The Problem

%TIPHOME% exists as stated in Response.txt but the installation fails at ${IAGLOBAL_INVALID_TIP22_LOCATION_BASED_NOT_FOUND}

Resolving The Problem

The issue can be resolved by following below steps:

* Run the de_lsrootiu.cmd command

e.g. for an administrator installation

C:\Program Files\IBM\Common\acsi\bin\de_lsrootiu.cmd.

* Check the %TIPHOME% path is set correctly in the Response.txt file as shown in the de_lsrootiu.cmd's output.

Example output, with %TIPHOME% location in bold font:

####################################


InstanceID[IU,TIPCore,mrid:http://w3.ibm.com/namespaces/2003/OS_componentTypes:Operating_System,2.2.0.15,C:\IBM\tivoli\tipv2,2ADC4A33F09F4E85AD27963E850290C3] 2ADC4A33F09F4E85AD27963E850290C3 TIPCore 2.2.0.15 mrid:http://w3.ibm.com/namespaces/2003/OS_componentTypes:Operating_System C:\IBM\tivoli\tipv2

####################################

Note : The sample_response.txt lists the %TIPHOME% as IAGLOBAL_TIP_HOME. The output from de_lsrootiu.cmd is XML and therefore may need to be redirected and viewed in an editor.

[{"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web GUI","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.4.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21661832