IBM Support

Analyst Excel Add-in Results In Error: Run-time error '429': ActiveX Component Can't Create Object

Troubleshooting


Problem

Unable to use the Analyst Excel Add-in following new installation of Planning 10.1.1 The following error occurs immediately when Excel is opened with the Analyst Add-in enabled. With the Analyst Add-in disabled error does not occur If one clicks End to the error message, Excel opens fine but one cannot utilize the Analyst Add-in.

Symptom

Error:
Microsoft Visual Basic
Run-time error '429':
ActiveX component can't create object
End

Cause

The Analyst Excel Add-in is pointing to an older version of the Analyst.xla file.

Environment

Planning 10.1.1 FP2
Office 2010 32 bit

Resolving The Problem

STEPS:
1. Open Excel and confirm location of the Analyst.xla file being used.
For Office 2010: In Excel>select File menu>Click Options>Click Add-Ins
Locate Analyst Add-in in the list and its location.

2. If not using the Analyst.xla file from the installation bin directory, change the location to the bin directory.
Click Go (at bottom of the Add-ins screen where it specifies Manage Excel Add-ins)
Select Analyst Add-in in the list and select Browse and locate Analyst.xla file in bin directory.
Select OK to pop-up message that file already exists.

3. If error persists:
From a working machine or from the Planning Administrator Server, copy the Analyst.xla file from bin
directory.

4. Backup the existing Analyst.xla in the bin directory of the non-working machine

5. Once done, delete the file and copy the Analyst.xla file (from Step 3) into the bin directory

6. Open Excel and Log onto the Analyst Excel Addin

[{"Product":{"code":"SSPN2D","label":"Cognos Planning"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Analyst ExcelAddIn","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21661396