Troubleshooting
Problem
The installation of DB2 on Windows fails with the following error: Error 1719.Windows Installer service could not be accessed. Contact your support personnel to verify that it is properly registered and enabled
Symptom
When installing DB2 on Windows 7, Vista, or 2008 Sever the following error message may occur:
"The Windows Installer Service could not be accessed. Contact your support personnel for assistance. Error 1719. Windows Installer service could not be accessed "
The following is an example of what may be written to the DB2 setup log:
MSI (s) (84:64) [10:19:04:511]: Note: 1: 1719
CustomAction setInstallLangCA returned actual error code 1601 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (84:64) [10:19:04:511]: Product: IBM Data Server Client -- Error 1719.Windows Installer service could not be accessed. Contact your support personnel to verify that it is properly registered and enabled.
Error 1719.Windows Installer service could not be accessed. Contact your support personnel to verify that it is properly registered and enabled.
Cause
This may be caused by a problem with Windows Installer Service. It may not be correctly installed or recent Operating System changes may have been made.
Environment
Windows 7 / Vista / 2008 Server
Diagnosing The Problem
The DB2 setup log can be found under the My Documents\DB2LOG\ folder. Open the log file that corresponds to the installation attempt that failed and look for an error such as the following:
" DB2COPY1 -- Error 1719.Windows Installer service could not be accessed. Contact your support personnel to verify that it is properly registered and enabled."
Resolving The Problem
Follow the suggestions given in this Microsoft Knowledgebase article:
http://support.microsoft.com/kb/2642495
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21661159