IBM Support

Managing Email Communication Templates

Question & Answer


Question

How do I determine who will receive an email for various Service Request (SR) approvals and notifications?

Cause

It is necessary to ensure that the appropriate users and groups get informed about SR/project information.

Answer

Familiarize yourself with 3 Applications in the Maximo admin user interface:

1. Communication Templates:


  Go To > System Configuration > Platform Configuration > Communication Templates

2. Roles:


  Go To > System Configuration > Platform Configuration > Roles

3. Database Configuration:


  Go To > System Configuration > Platform Configuration > Database Configuration

Using as an example the email template "PMRDPAPRREQ," we would like to know who in our organization should be receiving emails from this activity.

1. We first start by opening the "PMRDPAPRREQ" template from the Communication Templates application:


  Go To > System Configuration > Platform Configuration > Communication Templates



From this we can notice 3 things:
A. The short template description helps us to identify what this email would get generated from. In this case, it is to notify cloud administrators of an SR approval action needed.
B. The related object "SR" is a Maximo construct which we can review to get more details about the template.
C. The template is addressed "To: PMRDPCA" Role which we can review further to understand who could receive this email.

2. We can review the Role "PMRDPCA" to understand who could be receiving this type of email:
  Go To > System Configuration > Platform Configuration > Roles

From this we can see 2 things:
A. The Role "PMRDPCA" is a group of all cloud administrators
B. The related object "SR" can be viewed for more details.

3. Lastly to understand in further detail who could receive an email from this template, we can look at the "SR" object and view the Database Configuration Relationships:
  Go To > System Configuration > Platform Configuration > Database Configuration

From this we can see 3 things:
A. We are looking on the Relationships tab of the SR object.
B. The PMRDPCA role indicates the "Where Clause". This can be viewed as a quasi-SQL query - interpret this as what the interface will send to the Maximo database layer to collect data (personid user account information in this case) from your DB backend.
C. The Remarks section explains in lay-terms what this query would actually collect. In this case, all persons in the security group Cloud Administrators.

[{"Product":{"code":"SSFG5E","label":"Tivoli Service Automation Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"7.2.2;7.2.3;7.2.4;7.2.4.1;7.2.4.2;7.2.4.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSBH2C","label":"IBM Service Delivery Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"7.2.2;7.2.1;7.2.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21657986