Troubleshooting
Problem
You deploy the current snapshot through the Process Center and the installation process seems to be successful. However, when an application starts there a process template error occurs in the systemout.log file.
Symptom
The following error occurs in the systemout.log file:
ProcessContai E CWWBF0135E: Starting the process application 'APP_NAME'
failed due to pending process template updates.
ProcessContai E
com.ibm.websphere.management.exception.AdminException:
com.ibm.bpe.api.UnexpectedFailureException: CWWBA0010E: Unexpected
exception during execution.
...
Cause
When a previous version of the application was uninstalled, the process did not complete. As a result, some orphan data is left in the PROCESS_TEMPLATE_B_T table.
Diagnosing The Problem
Check the PROCESS_TEMPLATE_B_T table for the process template of the problem application that failed to start. Determine whether data exists in the table for the same named process template of the old version application that has already uninstalled. If the data exists, then the orphan data in that table is the reason why the application cannot start properly.
Resolving The Problem
To remove the orphan data, you can use the deleteInvalidProcessTemplate.py script, which is documented in the Deleting process templates that are no longer valid topic within the information center.
You might also find the following information and tools helpful:
- Listing information about process and task templates
- Database views for Business Process Choreographer
You can use the Business Process Choreographer database views to get the template details. - Delete human task templates that are no longer valid
After removing the invalid templates, restart the server. Check whether the applications are able to start after finishing the installation process.
Product Synonym
BPM
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Document Information
Modified date:
15 June 2018
UID
swg21657516