IBM Support

RSV-DST-0014 unable to deliver output (to filesystem)

Troubleshooting


Problem

Some report outputs configured to save to filesystem outside cognos gives intermittent error: RSV-DST-0014 unable to deliver output

Cause

This is often caused by the asynchronous connection between the report server and the monitor (ms) or delivery (dls) services timing out due to load / delays on the system.

Resolving The Problem

1. In IBM Cognos Administration -> Configuration -> Dispatchers and Services
2. Click the Properties icon in the top-right to edit the properties of the top-level Configuration object
3. Click the Settings tab, then click the Edit... link for the AdvancedSettings entry
4. Add the following 2 Parameter/Value pairs:
.
primary.wait.dls 360
primary.wait.ms 360
.
5. Click OK twice to save the changes
6. Drill down to the service level and check the properties of the Monitor and Delivery services to double-check that they are inheriting the advanced settings from the top level.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21655826