IBM Support

Unexpected error accessing JNDI logging into FileNet WorkplaceXT

Troubleshooting


Problem

After installing Workplace and WorkplaceXT both applications receive the same error logging in.

Symptom

After entering user credentials in Workplace or WorkplaceXT the following error and stack trace is displayed to the user:

com.filenet.api.exception.EngineRuntimeException:An unexpected error
occured accessing JNDI. [Code=null];
OMFC/TheNetwork/NoOp//API_UNEXPECTED_JNDI_ERROR

SERVER (id=4773e3aa. host=<SERVER.NAME> TRACE START:
org.omg/CORBA.NO_PERMISSION:the realsm do not match vmcid: 0x49424000
minor code: 300 completed: No

Cause

The Trusted Realm in the IBM WebSphere Server was in lower case on the server containing the WP and WPXT application while it was in upper case on the Content Engine Server. The entries must be identical.

Resolving The Problem

  1. Access WAS Console on the CE

  2. Go to Security

  3. Global Security

  4. Click on Configure

  5. Click on Trusted authentication realms-inbound

  6. Copied the Trusted Realm Name

  7. Access WAS Console for AE and XT

  8. Go to Security

  9. Global Security

  10. Click on Configure

  11. Click on Trusted authentication realms-inbound

  12. Paste the Trusted Realm Name

  13. Go Back to the Global Security Configure screen

  14. Paste the name into the Host field

  15. Go back to Trusted authentication realms-inbound

  16. Delete the previous entry

  17. Stop and restart the CE and AE\XT servers

[{"Product":{"code":"SSNW2F","label":"FileNet P8 Platform"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Application Engine","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21654265