Troubleshooting
Problem
After installing Workplace and WorkplaceXT both applications receive the same error logging in.
Symptom
After entering user credentials in Workplace or WorkplaceXT the following error and stack trace is displayed to the user:
com.filenet.api.exception.EngineRuntimeException:An unexpected error
occured accessing JNDI. [Code=null];
OMFC/TheNetwork/NoOp//API_UNEXPECTED_JNDI_ERROR
SERVER (id=4773e3aa. host=<SERVER.NAME> TRACE START:
org.omg/CORBA.NO_PERMISSION:the realsm do not match vmcid: 0x49424000
minor code: 300 completed: No
Cause
The Trusted Realm in the IBM WebSphere Server was in lower case on the server containing the WP and WPXT application while it was in upper case on the Content Engine Server. The entries must be identical.
Resolving The Problem
- Access WAS Console on the CE
- Go to Security
- Global Security
- Click on Configure
- Click on Trusted authentication realms-inbound
- Copied the Trusted Realm Name
- Access WAS Console for AE and XT
- Go to Security
- Global Security
- Click on Configure
- Click on Trusted authentication realms-inbound
- Paste the Trusted Realm Name
- Go Back to the Global Security Configure screen
- Paste the name into the Host field
- Go back to Trusted authentication realms-inbound
- Delete the previous entry
- Stop and restart the CE and AE\XT servers
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21654265