IBM Support

Unable to monitor Tomcat Application Server in TM1 Operations Console 10.2

Troubleshooting


Problem

After adding the details of application server in TM1 operations console for monitoring, the icon stays grey and can not open the Application Server monitor window in Monitor tab. Warning Message : "Application Server is not reachable"

Cause

Application Server is configured to use SSL

Environment

TM1 10.2

Resolving The Problem

Steps :

  1. Open Command prompt. Go to <TM1_Application_Server_Install>/tomcat/bin
  2. Open Tomcat configuration which you want to monitor from command prompt using command - tomcat6w.exe //ES//pmpsvc
  3. Go to Java tab -> Check Java Options set
  4. Change -Dcom.sun.management.jmxremote.ssl to false
  5. Restart Application Server from Windows Services panel or from Tomcat Application Server configuration window.
  6. Now you can monitor the application server in TM1 Operations Console.

Or ..
You could edit the <TM1Root>\bin64\service_pmpsvc.bat
Under rem Set JMX parameters section
Change -Dcom.sun.management.jmxremote.ssl to false

Save

Note : If you restart the Application Server from IBM Cognos configuration window the settings get reset to default.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1 Operations Console","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21653515