IBM Support

Max node size exceeded and XML parser limits exceeded errors when testing with the DataPower probe enabled

Troubleshooting


Problem

When using the DataPower probe during the development and testing of a service, users might see transactions abort with an error of "Max node size exceeded" or "XML parser limits exceeded".

Symptom

An error is seen in DataPower logs with Max node size or XML parser limits exceeded. The transaction can fail at any point of the processing rule depending upon the amount of data being processed by the probe for the next action in the rule.

An error message is logged with the following text, and an error rule is attempted with the specified error-code:

  • "Max node size exceeded" with an error-code of "0x00030009"
  • "XML parser limits exceeded" with an error-code of "0x00030003"

Cause

The DataPower probe must have the service's XML Manager property "XML Bytes Scanned" sufficiently large for the probe to be able to capture data and variables associated with the next processing action that is on the processing policy.

Environment

Development environments where the DataPower probe is used to debug the processing policy.


Note that the XML parser limits error is found during the non-XML processing. However, the error is not specific to the JSON or NON-XML traffic type rules. There might be non-XML processing in an XML traffic type rule.

Resolving The Problem

To resolve the failure, increase the value of the "XML Bytes Scanned" property to a value large enough to accommodate the XML requirements of the probe for the processing policy that is being tested.

[{"Product":{"code":"SS9H2Y","label":"IBM DataPower Gateway"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF009","label":"Firmware"}],"Version":"4.0.2;4.0.1;5.0.0;6.0.0;6.0.1;7.0.0;7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21653501