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** Troubleshooting ** "The request failed with HTTP status 405: Method Not Allowed"

Troubleshooting


Problem

User launches Controller client. User receives error.

Symptom

Example (Controller 10.1.1):
 
Error
An error occurred while trying to access the server.
http://servername/ibmcognos/cgi-bin/cognos.cgi?t=controller
[Details] [OK]

Error Details
The request failed with HTTP status 405: Method Not Allowed.

Cause

There are several possible causes for this error:
Scenario #1 - Gateway server's cgi-bin virtual directory's 'Handler Mappings' has not been configured correctly.
  • For more details, see separate IBM Technote #499331
 
Scenario #2 - (Old/legacy versions only) Gateway server has 32-bit BI components installed, and is using ISAPI, but the Application Pool has been configured to not allow 32-bit applications.
  • NOTE: This scenario is only relevant to old/unsupported/legacy versions of the software (which only supported 32-bit components). This scenario is not relevant to modern versions of Controller/CA which use 64-bit components.
Scenario #3 - Administrator has incorrectly configured the setting "Controller URI for gateway" inside "Cognos Configuration" on the Gateway server.
  • For more information, see separate IBM Technote #1653498
 
Scenario #4 - Incorrect 'bitness' level on the Gateway server.
  • For more information, see separate IBM Technote #1654607
  • NOTE: This scenario is only relevant to old/unsupported/legacy versions of the software (which only supported 32-bit components). This scenario is not relevant to modern versions of Controller/CA which use 64-bit components.

Environment

Scenario #2

Gateway has 32-bit BI components installed, and is configured to use ISAPI with 't=controller'

Resolving The Problem

Scenario #1

Reconfigure the Handler Mappings for the virtual directory 'cgi-bin' on the 'Gateway' server to be correct.

  • TIP: For more details, see separate IBM Technote #499331
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Scenario #2

NOTE: This scenario is only relevant to old/unsupported/legacy versions of the software (which only supported 32-bit components). This scenario is not relevant to modern versions of Controller/CA which use 64-bit components.
Fix: Reconfigure the relevant Application Pool to allow 32-bit applications.

On the Gateway server:

1. Open "Server Manager"

2. Locate the relevant Application Pool.


  • TIP: By default, this is "DefaultAppPool"

3. Right-click on this, and choose "Advanced Settings":

4. Modify the setting "Enable 32-Bit Applications" to be "True":

5. Click OK, and test.

  • Workaround: Reconfigure gateway server and client to use CGI (not ISAPI).
On the client device:
  1. Open up this folder: "C:\Program Files (x86)\ibm\IBM Cognos Controller\
  2. Open the file "CCR.exe.config" inside NOTEPAD.EXE
  3. Change the "WSSUrl" line to something similar to:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Scenario #3

Modify the setting for "Controller URI for gateway" to the correct value, for example:
http://APPSERVER:80/ibmcognos/controllerServer/ccrws.asmx
  • For more information, see separate IBM Technote #1653498
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Scenario #4

NOTE: This scenario is only relevant to old/unsupported/legacy versions of the software (which only supported 32-bit components). This scenario is not relevant to modern versions of Controller/CA which use 64-bit components.

Reconfigure the bitness level to be correct (e.g. bitness32).

  • TIP: For more details, see separate IBM Technote #1654607
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000Gmx2AAC","label":"Error"}],"ARM Case Number":"TS004069715","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Document Information

Modified date:
17 August 2020

UID

swg21653361