IBM Support

Recording on Dojo sub-menu items throws wrapped exception

Technote (troubleshooting)


Problem(Abstract)

Consecutive recording of the same sub-menu items throw wrapped exception in the recording monitor.

Symptom

If you recorded a View > Toolbars > Menu bar action (as seen below) and the consecutive action is View > Toolbars > Favorites bar, Rational Functional Tester throws an exception.

image


Cause

DOJO has not yet refreshed the dom of the page if an item from the same sub-menu is clicked consecutively.

Resolving the problem

You must perform any other action, for instance clicking any other control or a different menu item, before clicking an item from the same sub-menu.

This action initiates DOJO to refresh the dom of the page and update the properties of the sub-menu accordingly.


Document information

More support for: Rational Functional Tester
Record / Author tests

Software version: 8.2, 8.2.0.1, 8.2.0.2, 8.2.1, 8.2.1.1, 8.2.2, 8.2.2.1, 8.3, 8.3.0.1, 8.3.0.2, 8.5, 8.5.0.1

Operating system(s): Windows

Reference #: 1653337

Modified date: 22 October 2013