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C&DS 5 fix pack 2 patch.sh fails with: ERROR - CrtCDSresources.py failed

Troubleshooting


Problem

C&DS 5 fix pack 2 patch.sh fails with: ERROR - CrtCDSresources.py failed. The IBM Installation Manager portion of the fix pack application competed successfully.

Symptom

C&DS 5 fix pack 2 patch.sh fails with: ERROR - CrtCDSresources.py failed

Cause

This was a websphere pseudo cluster environment and during the running of the patch.sh websphere was down.

Environment

RHEL 5.7
C&DS 5 fix pack 2
Websphere 7.1
Oracle

Diagnosing The Problem

From the engine.log

Oct 02 2013 10:35:44 INFO : Deploy Deployables
Oct 02 2013 10:36:26 ERROR: The following error occurred while executing this line:
/opt/IBM/SPSS/Deployment/5.0/Server/setup/deploy-websphere.xml:264: The following error occurred while executing this line:
/opt/IBM/SPSS/Deployment/5.0/Server/setup/deploy-websphere.xml:292: ERROR - CrtCDSresources.py failed
com.ibm.spss.setup.ConfigException: The following error occurred while executing this line:
/opt/IBM/SPSS/Deployment/5.0/Server/setup/deploy-websphere.xml:264: The following error occurred while executing this line:
/opt/IBM/SPSS/Deployment/5.0/Server/setup/deploy-websphere.xml:292: ERROR - CrtCDSresources.py failed

From the patch_ant.log

[exec] WASX7023E: Error creating "SOAP" connection to host "localhost"; exception information: com.ibm.websphere.management.exception.ConnectorNotAvailableException: [SOAPException: faultCode=SOAP-ENV:Protocol; msg=; targetException=java.net.MalformedURLException]
[exec] WASX7213I: This scripting client is not connected to a server process; please refer to the log file /opt/IBM/WebSphere/AppServer/profiles/SPSSDmgr/logs/wsadmin.traceout for additional information.
[exec] WASX7017E: Exception received while running file "CrtCDSresources.py"; exception information: com.ibm.ws.scripting.ScriptingException: WASX7070E: The configuration service is not available.

From the wsadmin.traceout

[10/2/13 10:36:24:223 CDT] 00000000 AbstractShell A WASX7093I: Issuing message: "WASX7023E: Error creating "SOAP" connection to host "localhost"; exception information: com.ibm.websphere.management.exception.ConnectorNotAvailableException: [SOAPException: faultCode=SOAP-ENV:Protocol; msg=; targetException=java.net.MalformedURLException]"
[10/2/13 10:36:24:246 CDT] 00000000 AbstractShell E WASX7120E: Diagnostic information from exception with text "com.ibm.websphere.management.exception.ConnectorException
java.lang.reflect.InvocationTargetException: java.lang.reflect.InvocationTargetException
" follows:

com.ibm.websphere.management.exception.ConnectorException: ADMC0016E: The system cannot create a SOAP connector to connect to host localhost at port 8879.
[10/2/13 10:36:24:367 CDT] 00000000 AdminAppClien W WASX7072E: The control service is not available.
[10/2/13 10:36:24:783 CDT] 00000000 AdminAppClien W WASX7206W: The application management service is not running. Application management commands will not run.
[10/2/13 10:36:24:785 CDT] 00000000 AdminCmdClien W WASX7198W: The configuration service is not running. Configuration commands will not run.
[10/2/13 10:36:24:785 CDT] 00000000 AdminCmdClien W WASX8011W: AdminTask object is not available.
[10/2/13 10:36:25:638 CDT] 00000000 AbstractShell A WASX7303I: The following options are passed to the scripting environment and are available as arguments that are stored in the argv variable: "[-update]"
[10/2/13 10:36:25:639 CDT] 00000000 AbstractShell A WASX7091I: Executing script: "CrtCDSresources.py"
[10/2/13 10:36:25:775 CDT] 00000000 AbstractShell E WASX7120E: Diagnostic information from exception with text "com.ibm.ws.scripting.ScriptingException: WASX7070E: The configuration service is not available.

Resolving The Problem

When running the patch.sh portion of the C&DS 5 fix pack 2, the instructions state that in a Websphere clustered environment the Deployment Manager and the Node Agent need to be up and running; only the application server is to be ended. Make sure that the Deployment Manager and Node Agent are active when running the patch.sh in a Websphere clustered environment.
Prior to installation

* Back up SPSS Collaboration and Deployment Services Repository database.
* Verify that the application server or cluster is in the following state:
o WebSphere standalone: The application server must be stopped.
o WebSphere managed: The application server(s) or cluster must be stopped; the Deployment Manager and Node Agent(s) must be running.

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Document Information

Modified date:
16 June 2018

UID

swg21651950