Accessing RTC dashboards results in HTTP 400 error

Technote (troubleshooting)


Problem(Abstract)

Attempts to navigate to the project dashboard results in HTTP 400 error with IBM Rational Team Concert (RTC).

Symptom

When opening project dashboards or clicking on the 'About the Application' link in Rational Team Concert, the following error occurs:


An error occurred while retrieving the dashboard:
Unable to load /ccm/proxy?
uri=https://<server:port>/jts/dashboards/2087?contentType=application%2Frdf%25xml status:400

Note: The 'About the Application' displays the status:400 error, but with different URL.

In the ccm.log file, the following error is present:
[ WebContainer : 0] ERROR net.jazz.ajax.service.internal.http.ProxyServlet - GET https://<server:port>/<ccm_context>/proxy
?uri=https%3A%2F%2F<server>%3A<port>%2Fjts%2Fdashboards%2F2087%3FcontentType%3Dapplication%252Frdf%2525xmlHEADER: Host = <server:port>

...
Parameter: uri = [https://<server:port>/jts/dashboards/2087?contentType=application%2Frdf%25xml]

org.eclipse.core.runtime.AssertionFailedException: null argument:The local application's root services could not be fetched, contained invalid content, or was missing the required entry for jfs:oauthDomain
at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)

Cause

The following web container's custom properties are missing. These entries are added to force IBM WebSphere Application server to honor host headers.

trusthostheaderport = true
com.ibm.ws.webcontainer.extracthostheaderport = true


Environment

Distributed CLM environment

  • Reverse Proxy configured

Diagnosing the problem

You can enable the following log4j entry on the CCM server by adding the following entry to log4j.properties and reloading the log settings:log4j.logger.org.apache.http.impl.conn=DEBUG

This will result in the following output in ccm.log:
[ Worker-0] DEBUG org.apache.http.impl.conn.tsccm.ConnPoolByRoute - Creating new connection [HttpRoute[{s}->https://<server:port>]]
[ Worker-0] DEBUG che.http.impl.conn.DefaultClientConnectionOperator - Connecting to <server:port>
[ Worker-0] DEBUG org.apache.http.impl.conn.DefaultClientConnection - Sending request: GET /<ccm_context>/rootservices HTTP/1.1
[ Worker-0] DEBUG org.apache.http.impl.conn.DefaultClientConnection - Receiving response: HTTP/1.1 404 Not Found
[ Worker-0] DEBUG org.apache.http.impl.conn.DefaultClientConnection - Connection shut down
[ Worker-0] DEBUG e.http.impl.conn.tsccm.ThreadSafeClientConnManager - Released connection is not reusable.
[ Worker-0] DEBUG org.apache.http.impl.conn.tsccm.ConnPoolByRoute - Releasing connection [HttpRoute[{s}->https://<server:port>]][null]
[ Worker-0] DEBUG org.apache.http.impl.conn.tsccm.ConnPoolByRoute - Notifying no-one, there are no waiting threads
[ WebContainer : 1] ERROR net.jazz.ajax.service.internal.http.ProxyServlet - GET https://<server:port>/<ccm_context>/proxy
?uri=https%3A%2F%2F<server>%3A<port>%2Fjts%2Fdashboards%2F2087%3FcontentType%3Dapplication%252Frdf%2525xmlHEADER: Host = <server:port>

Resolving the problem

Add the following web container's custom properties to force WebSphere to honor host headers:


    trusthostheaderport = true
    com.ibm.ws.webcontainer.extracthostheaderport = true

This is also documented in the article: Configuring Enterprise CLM Reverse Proxies: WebSphere 8 and IHS 8

Leverage the Jazz Community

The Jazz based products have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.


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Document information


More support for:

Rational Team Concert
Proxy Server

Software version:

3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 3.0.1.6, 4.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4

Operating system(s):

AIX, Linux, Windows

Reference #:

1651646

Modified date:

2013-10-02

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