During a two stage Git adapter upgrade, the upgrade_addition.sh script aborts when it runs

Technote (troubleshooting)


Problem(Abstract)

Attempts to run the upgrade_additions.sh script on Gitweb or Gerrit results in the message "The Git adapter public URL could not be determined from <path>/oslcConfig.js."

Symptom

You upgraded the Git adapter from version 1.0 to 1.1. You then upgraded the Git adapter from version 1.1 to 1.1.0.1. During the upgrade from 1.1 to 1.1.0.1 you ran the upgrade_additions.sh script. The script aborted with the message:

The Git adapter public URL could not be determined from <path>/oslcConfig.js. You may have specified a gitweb server that has already been upgraded or an incorrect gitweb server location. Confirm that you have specified the correct gitweb server location and try the upgrade again. Aborting.

Cause

This issue is identified as a product defect.

Resolving the problem

WORKAROUND:

  1. Open the oslcConfig.js file in the static directory of the Gitweb installation directory or the Gerrit installation directory.
  2. Replace the text adapted-project with logical-adapter on the OSLC.GIT.LogicalAdapterURL entry.
  3. Save the file.
  4. Run the upgrade_addition.sh script in the static directory on the Gitweb or the Gerrit installation directory.
  5. Continue your software upgrade following the steps in the Upgrading the adapter software documentation topic.

Related information

Latest support documents

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Lifecycle Integration Adapters
Rational Adapter for Git

Software version:

1.1.0.1

Operating system(s):

Linux

Software edition:

Standard

Reference #:

1651528

Modified date:

2013-10-01

Translate my page

Machine Translation

Content navigation