IBM Support

Unable to navigate in Active Report using Data Iterator

Troubleshooting


Problem

Active Report that uses a Data Iterator does not allow the user to navigate each Data Items in the Data Deck.

Symptom

User expecting to see a Dot for each Data Item but only one Dot is shown when run and viewed in Cognos Viewer.

Cause

Data Iterator object is located within the Data Deck object.

Resolving The Problem

The layout of the report had the Data Iterator object in a table that was located within the Data Decks drop area intended for data containers such as Lists, Crosstabs or Charts.

To resolve the issue ensure that the Data Iterator is not located in the Data Deck object.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Studio","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2;10.1.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21651067