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A possible solution for a -952 error when seen on AIX while a remote Kerberos/AD user account is authenticating to IDS

Troubleshooting


Problem

The -952 error is generally a bad account/password combination. However when there is 100% confidence that the account/password combination is correct, a -952 error can still occur. This article explains one scenario and a possible solution for that problem.

Symptom

Assumptions:

  1. 100% confidence that the account/password combination is correct
  2. The OS is properly configured to authenticate Kerberos/AD user accounts
  3. The user account is a remote Kerberos/AD account
  4. AIX OS

A -952 error is reported in the server message log and possibly a -951 error to the client.

Cause

The remote AD server may not have a crypt hash password stored for the user account. If so it will return "*" for the crypt hash password value. This value does not match the crypt hash value of the passed-in password.

Resolving The Problem

Take one of the following actions where applicable:

  1. Ensure the permissions of the oninit binary are rwsr-sr--, owner is root and group is informix
  2. Try running the instance as user root instead of user informix
  3. Use some other form of authentication such as PAM or SSO

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Document Information

Modified date:
16 June 2018

UID

swg21650838