IBM Support

Error: "gautodetect.pl is not installed" in IBM InfoSphere Guardium

Troubleshooting


Problem

When using DB Discovery in IBM InfoSphere Guardium, an error appears . From the GUI Tools -> Config & Control -> Auto-discovery Configuration the following error appears gautodetect.pl is not installed. Please contact your system administrator to install the ad-hoc patch from the CLI.

Cause

The gautodetect component has not been installed.

Resolving The Problem

To enable DB Discovery functionality, please apply the following ad-hoc patch from IBM Fix Central

VersionPatch NoFix Central Name Patch file name
8.018.01p01GuardiumV8.Database_Discovery_PatchSqlGuard-8.01p01.tgz.enc
8.208.2p01InfoSphere_Guardium_DB_Discovery_Activation_Patch_8.2.0 SqlGuard-8.2p01.tgz.enc
9.09.0p01 InfoSphere_Guardium_DB_Discovery_Activation_Patch_9.0 SqlGuard-9.0p01.tgz.enc

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"9.0;8.2;8.0.1","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21650742