External Excel File Data Connection

Technote (troubleshooting)


Problem(Abstract)

Unable to successfully test the connection when creating an External Microsoft Excel File data source.
- DataSourceCredentials is setup correctly with a domain\user
- Accessing the shared files using the same credentials is successful

Symptom

No errors are recorded/displayed on screen. Simply that the Test Connection failed.


Cause

Missing permission on the CDM application server

Resolving the problem

Ensure that only ONE user is accessing CDM while troubleshooting the issue.

1. Logout of CDM (all users should be logged out)

2. Increase the logging level; from INFO to ALL: C:\inetpub\wwwroot\CognosDM-Server\Config\Logging.config


<logger name="Ibm.CognosDM">
<level value="ALL" />
<appender-ref ref="ApplicationLog" />
</logger>

3. Logon CDM and duplicate the issue (Test Connection of an Excel data source)
4. Review the Application log
5. In this particular scenario, we found the following: c:\windows\temp\nnnn.tmp Access is Denied
6. Add the DataSourceCredentials user to the c:\windows\temp with full control.
7. Test the Excel File data source once more.
8. IMPORTANT: Reduce the logging level back to INFO
(Note. Leaving the logging level to ALL will impact the application in ALL aspects)


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Document information


More support for:

Cognos Disclosure Management
Cognos Disclosure Management

Software version:

10.2, 10.2.1

Operating system(s):

Windows

Reference #:

1650020

Modified date:

2013-09-16

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