IBM Support

Stub cannot be started as "no agents" are available

Troubleshooting


Problem

Attempts to start a stub in IBM Rational Test Control Panel (RTCP) fail with error "There are currently no agents registered...".

Symptom

  • You have created a stub in IBM Rational Integration Tester (RIT).

  • You have published the stub to RTCP.

  • You wish to run this stub on a remote IBM Rational Integration Tester Agent (RIT-Agent).

  • You select the Start stub option on the VIE administration page of RTCP.
    The following error is displayed:

    There are currently no agents registered with Rational Test Control Panel to which stubs can be published

Cause

There are no RIT-Agents registered with RTCP for the domain and environment that you are using.

RIT-Agents are registered with your domain and environment in RTCP but they are not of type RTVS.

Resolving The Problem

The RIT-Agent comes with IBM Rational Test Virtualization Server (RTVS) and IBM Rational Performance Test Server (RPTS). The ability to run stubs is included with RTVS, it is not included with RPTS. Consult your Sales representative if you need to upgrade to RTVS.

Consider the following steps to resolve the issue.

  1. Check the Agents page in RTCP to confirm which Agents are running.

  2. Verify that you have at least one Agent of type RTVS with OK status.

    When RIT-Agent is installed you must select "Rational Test Virtualization Server" as the bundle that it is installed with.

    Re-install and select this option if you have purchased RTVS.

  3. Verify that Agents are configured to register with the RTCP server you are using.

    a) Open Agent.config in the config folder of the RIT-Agent installation.
    b) Edit the following setting for your server:

    <rtcpURL value="http://my_RTCP_server:7819/RTCP"/>

    c) Check the <domain> entries to ensure that the Agents also register with the domain and environment you are using.

  4. Re-start the Agent to pick up any changes.

    For Windows systems restart the service IBM RIT Agent.

    For non-Windows systems it will depend on how the Agent was started. There might be a start/stop script in the init folder. If there is no stop script you can kill the process.
    Perform a process listing and search for the string " /opt/IBM/RIT-Agent//jre/bin/javaw " where " /opt/IBM/RIT-Agent " is the installation location.

    Verify on the RTCP Agents page.

  5. Check any firewall restrictions that prevent the Agent from registering with RTCP.

    Refer to technote: Network port numbers used by IBM Rational Test Workbench components


Consult your software license entitlement to ensure that you install and use RIT-Agents in compliance with it.

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Document Information

Modified date:
29 September 2018

UID

swg21649533