Hotfix Install throws error: Support for this platform is not available in this installation kit

Technote (troubleshooting)


Problem

Hotfix Install throws error: Support for this platform is not available in this installation kit

Cause

In one particular case, the problem turned out to be with the install.dat file which either was corrupt or had permissions issue.

Environment

Domino 853FP3 on Solaris 10

Diagnosing the problem

Installation of Domino hotfixes on Solaris 10 halts with the following errors:

Installer is initializing. It may take a few minutes, please, wait.\n
Support for this platform is not available in this installation kit.\n
Unable to locate Perl on this system.\n

You must create the environment variable NUI_NOTESDIR as path of the directory\nthat contains notes/latest.
E.g., for the default path /opt/ibm/domino/notes/latest \n NUI_NOTESDIR=/opt/ibm/domino\n export NUI_NOTESDIR for default path /opt/ibm/lotus/notes/latest\n NUI_NOTESDIR=/opt/ibm/lotus\n export NUI_NOTESDIR
is not a valid Domino directory: it doesn't contain notes/latest.
This is an AIX64 Domino install kit, please use Domino kit for AIX32 platform.
This is an AIX32 Domino install kit, please use Domino kit for AIX64 platform.
This is an Linux64 Domino install kit, please use Domino kit for Linux32 platform.
This is an Linux32 Domino install kit, please use Domino kit for Linux64 platform.

+ echo IBM Domino for Unix Install Program
IBM Domino for Unix Install Program
+ echo ------------------------------------
------------------------------------
+ echo Installer is initializing. It may take a few minutes, please, wait.\n
Installer is initializing. It may take a few minutes, please, wait.

+ [ -z sol ]
+ [ != sol -a != "sol" ]
+ echo Support for this platform is not available in this installation kit.\n
Support for this platform is not available in this installation kit.

+ echo kitArchType =
kitArchType =
+ exit 1


The hotfix had no issues and the installation was tested by IBM. The errors during the installation related to Platform and Perl were incorrect and misleading.

Perl -v command can be used to check if a supported version perl runtime was installed on the target system.


Related Technotes:
Title: How to install a Domino server hotfix on UNIX platforms
Doc #: 1381950
URL: http://www.ibm.com/support/docview.wss?uid=swg21381950

Title: Installer for Domino Interim Fixes & Fix Packs built 9 July 2012 or later requires Perl distribution on Unix & Linux platforms
Doc #: 1600910
URL: http://www.ibm.com/support/docview.wss?uid=swg21600910


Resolving the problem

In this case replacing install.dat from /opt/lotus/notes/sunspa/853FP3 worked and hotfix install ran fine thereafter. One should also confirm the file has the right permissions


Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Domino
Deployment

Software version:

8.5, 8.5.1, 8.5.2, 8.5.3, 8.5.3.1, 8.5.3.3

Operating system(s):

Solaris

Software edition:

All Editions

Reference #:

1649036

Modified date:

2013-09-10

Translate my page

Machine Translation

Content navigation