IBM Support

OpenPages Framework Model Generator service does not start

Troubleshooting


Problem

Starting OpenPages Framework Model Generator service from within Windows Services explorer may fail to start.

Symptom

Windows OS may throw a generic message that service could not be started.

Cause

IT Administrators may have accidentally uninstalled JDK 1.5, which is referred by OpenPages Framework Model Generator service

Environment

Windows 2003, OpenPages 5.5.2.x

Diagnosing The Problem

Check the logs under tomcat directory located under - ..\OpenPages\CommandCenter\apache-tomcat\logs. Logs may indicate that the JDK 1.5 path is missing.

Also check the following .exe file - ..\OpenPages\CommandCenter\apache-tomcat\bin\tomcat5w.exe and open the JAVA tab, which would have the JDK 1.5 path for jvm.dll file.

Resolving The Problem

Install JDK 1.5 if it is uninstalled from the system or if the JDK 1.5 is located in a different path then update the JDK 1.5 path in Tomcat as follows -

1) Run the following .exe file - ..\OpenPages\CommandCenter\apache-tomcat\bin\tomcat5w.exe

2) open JAVA tab and ensure that the JDK path is correct.

[{"Product":{"code":"SSFUEU","label":"IBM OpenPages with Watson"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Financial Controls Management","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.5.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21648812