"This file is not in a recognizable format" when running report after having changed Controller password

Technote (troubleshooting)


Problem(Abstract)

If the user changes their Controller password and then (without exiting Controller and re-launching Controller) tries to run an Excel-based report, they receive an error.

Symptom

Imagine a scenario where:

  • 'bad' user is called 'BADUSER'
  • Controller administrator (e.g. 'ADM') logs onto Controller, and clicks "Maintain - Rights - Users" and clicks on 'BADUSER'
  • Administrator sees that the user is set to "Inactive" (this is what happens the user after 3 attempts to run the report - see later) and closes the menu
  • Administrator changes BADUSER to "Active" and resets the user's password

Next:
  • The 'bad' user now logs on as BADUSER with this new password
  • During the logon process, user is prompted to change the password. Therefore he/she changes it (i.e. directly after logging into Controller) to a new password
  • BADUSER clicks "Reports - Run" and chooses/runs a user-defined report
  • However, when they click "Preview" or "Send to Application" an error appears:

This file is not in a recognizable format
  • If the user clicks OK, they can re-try running the report
  • If the user tries running the report 3 times, then the user gets set to 'inactive' again.
    • Therefore the administrator must now change BADUSER back to "Active" (and create a new password) to allow the bad user back into the system.

Cause

There are many potential causes for this error.

  • For more examples, see separate IBM Technote #1647017.
    This Technote specifically relates to the scenario where the cause is a code production problem (defect reference PM57170) in Controller.

  • Environment

    Controller versions before 10.2.1 FP1 (10.2.5110.85).

    Resolving the problem

    Fix:

    Upgrade to Controller 10.2.1 Fix Pack 1 (10.2.5110.85) or later.

    Workaround:
    Ensure that all users (after they change their password) immediately close Controller.

    • In other words, if you log out and back in (after changing the password) then the reports work OK.

    Related information

    APAR PM57170
    1647017 - ** Troubleshooting ** Error 'The file is not

    Document information


    More support for:

    Cognos Controller
    Controller

    Software version:

    10.1, 10.1.1, 10.2.0, 10.2.1

    Operating system(s):

    Windows

    Reference #:

    1646937

    Modified date:

    2015-06-16

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