IBM Support

Reclaim process appears hung

Troubleshooting


Problem

The Tivoli Storage Manager server reclamation process is run to reclaim a storage pool containing very small files. The reclaim process appears to hang.

Symptom

Execute the following command to reclaim a storage pool:

reclaim stgpool DIRPOOL threshold=99"

The process starts and does not show any indication of progress. For example :

1 Space Reclamation Offsite Volume(s) (storage pool DIRPOOL), Moved Files: 0, Moved Bytes: 0, Unreadable Files: 0, Unreadable Bytes: 0. Current Physical File (bytes): None

Cause

The tape required for reclamation contains a large number of objects.

Diagnosing The Problem

The issue only happens on certain storage pools. In this example, the DIRPOOL is a storage pool that contains only directory data. The storage pool is configured as a storage pool destination in a backup copygroup and its associated management class is used with the DIRMC client option. In this example, the DIRPOOL uses LTO5 tapes, which have large capacity. As a result, one LTO5 tape can contain a large amount of directory data. The reclamation process needs to process the object on the tape before data movement. The more objects are on the tape, the longer this process will take.

Resolving The Problem

Stop using DIRMC or send DIRMC data to a storage pool with smaller volumes.

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Document Information

Modified date:
17 June 2018

UID

swg21646495