IBM Support

Integrity Checker repair mode fails

Troubleshooting


Problem

Running 7.1 Integrity Checker in repair mode can fail and corrupt the database.

Symptom

While re-populating the Maximo indexes, Integrity Checker fails with:

com.inet.tds.at: Msg 2601, Level 14, State 1, Line 1, Sqlstate 23000
[CHL-POWTESTW1]Cannot insert duplicate key row in object 'dbo.maxsyskeys' with unique index 'maxsyskeys_ndx1'.

Cause

A software bug in Integrity Checker causes it to try to populate multiple rows in table MaxSysKeys using the same value for MaxSysKeysID. Since MaxSysKeysID must be unique, the second attempt to apply the same value causes Integrity checker to fail.

Environment

Problem occurs on SQL Server databases only.

Diagnosing The Problem

If the result of this query is a value greater than 0 and less than 5, the database is corrupted:

Select count(*) From maxsyskeys

Resolving The Problem

A software fix is available for this bug. Apply any hotfix released after August 10, 2011. Once the hotfix is applied, run Integrity Checker again in repair mode. This will repair the corrupted database.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Upgrade Integ Checker","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSKTXT","label":"Tivoli Change and Configuration Management Database"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21646429