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ANR2968E Database backup terminated. DB2 sqlcode: -2033. DB2 sqlerrmc: 610

Troubleshooting


Problem

An IBM Spectrum Protect server BACKUP DB command fails with an ANR2968E, sqlcode -2033 and sqlerrmc 610.

Cause

The 610 API error code means that the system is unable to open the message txt file.

Diagnosing The Problem

The following message is seen in the IBM Spectrum Protect server activity log:

ANR2968E Database backup terminated. DB2 sqlcode: -2033 sqlerrmc: 610.

Explanation of the "sqlerrmc: 610" Tivoli Storage Manager API return code:

0610 E DSM_RC_NLS_CANT_OPEN_TXT Unable to open message text file.

Explanation
The system is unable to open the message txt file (dscenu.txt or dsmclientV3.cat for AIX). On the AS/400 platform this file is QANSAPI/QAANSENU(TXT).

System action
The system returns to the calling procedure.

User response
Verify that the dscenu.txt file is in the directory pointed to by DSMI_DIR. For AIX, verify that the dsmclientV3.cat file has a symbolic link to /usr/lib/nls/msg/<locale>/dsmclientV3.cat .

Note: See URL section for online API documentation.

Resolving The Problem

To resolve the ANR2968E, sqlerrmc 610 verify the following:

  • Check the section "Preparing the database manager for backup" from the Tivoli Storage Manager Server installation guide and follow the step by step configuration.


  • Note: See URL section for online documentation.
  • Check the DSMI_DIR variable point to the API directory. (Default path for the TSM server 64bit installation: C:\Program Files\Common Files\Tivoli\TSM\api64)
  • Add the DSMI_DIR variable in the tsmdbmgr.env file. Be aware that adding the DSMI_DIR variable in the tsmdbmgr.env file must be done eliminating the blank spaces from the path.


  • Example: DSMI_DIR=c:\Progra~1\common~1\tivoli\tsm\api64
  • Check if the dsc*.txt file exists in the directory specified by the DSMI_DIR environment variable.
  • Check the registry key HKEY_LOCAL_MACHINE/SOFTWARE/IBM/ADSM/CurrentVersion/Api64/Path is set properly to point to the API path.
  • Check if the DB2 variable DB2_VENDOR_INI is configured properly to point to the tsmdbmgr.env file. In case of spaces in the path that contains the tsmdbmgr.env file, it must be specified with the double quotes with the db2set command.


  • Example: db2set -i server1 DB2_VENDOR_INI="C:\Program Files\tivoli\tsm\server1\tsmdbmgr.env"

Note: After every change to the configuration a db2stop and a db2start must be issued.

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Document Information

Modified date:
17 June 2018

UID

swg21645771