IBM Support

Information Server IAAdmin fails during installation

Troubleshooting


Problem

When installing InfoSphere Information Server to a WebSphere cluster configuration IAAdmin may fail and the installation stops.

Symptom

Examine the installation log for the following error stack trace:

2013-07-26T13:05:57.815, INFO: CDIIN2753I:Command Array: /bin/sh /opt/IBM/InformationServer/ASBServer/bin/IAAdmin.sh -user isadmin -password ******** -host localhost -port 80 -installPredefinedRules /opt/IBM/InformationServer/ASBServer/lib/GeneralRules.jar -locale en_US, env = null, workingDir =/opt/IBM/InformationServer/ASBServer/bin
2013-07-26T13:05:59.321, WARNING: com.ibm.is.install.core.CommonProcess Exit Code: 1, Info: /opt/IBM/InformationServer/ASBServer , [Fatal Error] :1:50: White spaces are required between publicId and systemId.
org.xml.sax.SAXParseException: White spaces are required between publicId and systemId.
at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
at com.ascential.investigate.api.cli.APICommandLineHandler.deployPredefinedRules(APICommandLineHandler.java:1211)
at com.ascential.investigate.api.cli.APICommandLineHandler.processCommand(APICommandLineHandler.java:453)
at com.ascential.investigate.api.cli.APICommandLineHandler.executeCLI(APICommandLineHandler.java:351)
at com.ascential.investigate.api.cli.APICommandLineHandler.main(APICommandLineHandler.java:301)
Exception in thread "main" java.lang.Error: org.xml.sax.SAXParseException: White spaces are required between publicId and systemId.
at com.ascential.investigate.api.cli.APICommandLineHandler.deployPredefinedRules(APICommandLineHandler.java:1231)
at com.ascential.investigate.api.cli.APICommandLineHandler.processCommand(APICommandLineHandler.java:453)
at com.ascential.investigate.api.cli.APICommandLineHandler.executeCLI(APICommandLineHandler.java:351)
at com.ascential.investigate.api.cli.APICommandLineHandler.main(APICommandLineHandler.java:301)
Caused by: org.xml.sax.SAXParseException: White spaces are required between publicId and systemId.
at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
at com.ascential.investigate.api.cli.APICommandLineHandler.deployPredefinedRules(APICommandLineHandler.java:1211)
... 3 more
2013-07-26T13:05:59.329, SEVERE: com.ibm.is.install.engine.runtime.InstallEngine

com.ibm.is.install.exception.ActionException: CDIIN5123E: ExecuteScriptAction failed: the process returned error code 1:
[Fatal Error] :1:50: White spaces are required between publicId and systemId.
org.xml.sax.SAXParseException: White spaces are required between publicId and systemId.
at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
at com.ascential.investigate.api.cli.APICommandLineHandler.deployPredefinedRules(APICommandLineHandler.java:1211)
at com.ascential.investigate.api.cli.APICommandLineHandler.processCommand(APICommandLineHandler.java:453)
at com.ascential.investigate.api.cli.APICommandLineHandler.executeCLI(APICommandLineHandler.java:351)
at com.ascential.investigate.api.cli.APICommandLineHandler.main(APICommandLineHandler.java:301)
Exception in thread "main" java.lang.Error: org.xml.sax.SAXParseException: White spaces are required between publicId and systemId.
at com.ascential.investigate.api.cli.APICommandLineHandler.deployPredefinedRules(APICommandLineHandler.java:1231)
at com.ascential.investigate.api.cli.APICommandLineHandler.processCommand(APICommandLineHandler.java:453)
at com.ascential.investigate.api.cli.APICommandLineHandler.executeCLI(APICommandLineHandler.java:351)
at com.ascential.investigate.api.cli.APICommandLineHandler.main(APICommandLineHandler.java:301)
Caused by: org.xml.sax.SAXParseException: White spaces are required between publicId and systemId.
at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
at com.ascential.investigate.api.cli.APICommandLineHandler.deployPredefinedRules(APICommandLineHandler.java:1211)
... 3 more

Cause

In some cases this is an indication that the front end HTTP Server is not handling HTTP requests for Information Analyzer because the HTTP Server plugin has not refreshed the plugin-cfg.xml information. If the following message shows up in the HTTP Server error_log:

ws_common: websphereShouldHandleRequest: Config reloading FAILED; using old configws_common: websphereUpdateConfig: Failed to stat plugin config file: /opt/IBM/Plugins/config/webserver1/plugin-cfg.xml
ws_common: websphereBeginRequest: Config reloading FAILED; using old configws_common: websphereUpdateConfig: Failed to stat plugin config file: /opt/IBM/Plugins/config/webserver1/plugin-cfg.xml
ws_common: websphereShouldHandleRequest: Config reloading FAILED; using old configws_common: websphereUpdateConfig: Failed to stat plugin config file: /opt/IBM/Plugins/config/webserver1/plugin[Fri Jul 26 13:05:59 2013] [error] [client 127.0.0.1] (13)Permission denied: access to /InformationAnalyzer/publicRules denied

then there are incorrect permissions on the directory where plugin-cfg.xml is stored.

Resolving The Problem

This error is not fatal, but it will cause the installation to stop and request input from the user to either:

  • Retry failed action
  • Continue installation
  • Exit installation

  • Before selecting any action, correct the permissions where plugin-cfg.xml is stored and restart the web server. In this example, the plugin is stored at
    /opt/IBM/Plugins/config/webserver1/plugin-cfg.xml

    Each of the directories in this path, as well as plugin-cfg.xml, must have 755 permissions. This enables the plugin to determine if plugin-cfg.xml has changed and subsequently reload it to use the most current configuration. After correcting the permissions, restart the web server. Then select Retry failed action.

    Note, if the web server is remote, see technote at http://www-01.ibm.com/support/docview.wss?uid=swg21662133 for an additional IAAdmin failure scenario and resolution.

    [{"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1.2.0;9.1.0.1;9.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

    Document Information

    Modified date:
    16 June 2018

    UID

    swg21645612