IBM Support

Enable diagnostics in the FlashCopy Manager MMC GUI

Troubleshooting


Problem

Useful Microsoft Management Console (MMC) function to gather overall diagnostics, log files and traces.

Cause

The MMC user interface offers a comprehensive diagnostics collection.
It includes configuration files, trace files and diagnostics of the MMC itself.

Resolving The Problem

1. Start the MMC GUI using the Desktop Icon, for example for Data Protection for Microsoft SQL Server):



2. Browse to Protect and Recover Data and highlighted the desired application:



3. Right-click the highlighted application and choose Properties:



4. On the next window click on Diagnostics:



When using diagnostics the first time, diagnostics are already running. Please hit the "End" Button to disable diagnostics first.
Confirm the Dialog to restart CAD



5. Choose Complete Mode for enabling tracing of all components:



6. Press Begin to start gathering of trace files of diagnostics.
Confirm the Dialog to restart CAD
Note:
You may also start the Screenshot Utility to create some screenshots of the MMC



Screenshot utility starts in a different window:


7. Use MMC GUI and perform all actions required to reproduce the error.
After error occurred you have to stop diagnostics.
Note:
When the MMC GUI crashed or hangs you can use task manager to end it and restart
MMC GUI

8. Collect diagnostics:
Open diagnostics dialog again and click End Button
Confirm the CAD restart dialog
MMC is now collecting all diagnostics and copying them to the following directory:
C:\Program Files\Tivoli\FlashCopyManager\ProblemDetermination

9. You may choose to copy diagnostics to a separate folder or send it via email (you need to have SMTP configured in MMC to use this functionality)



Use Select All button before clicking on Copy or E-mail.
Note:
You may also gather diagnostics manually using Windows Explorer and access:
C:\Program Files\Tivoli\FlashCopyManager\ProblemDetermination

10. Send full set of diagnostics to IBM support following technote
How to upload files to support:
http://www-304.ibm.com/support/docview.wss?uid=swg21153852

[{"Product":{"code":"SS36V9","label":"Tivoli Storage FlashCopy Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"FlashCopy Manager MMC Snapin","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.1;3.2;4.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSTG2D","label":"Tivoli Storage Manager for Mail"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS Exchange","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3;6.4;7.1","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSTFZR","label":"Tivoli Storage Manager for Databases"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS SQL","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3;6.4;7.1","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSERFV","label":"IBM Spectrum Protect Snapshot"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1.0;8.1.2","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSER7G","label":"IBM Spectrum Protect for Databases"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS SQL","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1.0;8.1.2","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"SSERBW","label":"IBM Spectrum Protect for Mail"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS Exchange","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1.0;8.1.2","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
01 February 2022

UID

swg21644844