Troubleshooting
Problem
A Tivoli Storage Manager server instance is modified to run with the instance userid instead of the root userid. When the server is restarted, the ANR9905W error is logged when the server tries to access existing file volumes.
Symptom
The following messages are logged in the server activity log :
ANR9905W Unable to open file /tsmdata/filepool/12345678.bfs. The file access permissions do not allow the specified action.
ANR8501E System return code 13 received opening volume /tsmdata/filepool/12345678.bfs with file name /tsmdata/filepool/12345678.bfs
ANR1401W Mount request denied for volume /tsmdata/filepool/12345678.bfs - mount failed.
Cause
Incorrect ownership and/or permissions on volume
Diagnosing The Problem
Run the "ls -la" command to verify the ownership and permissions of the affected file. For example :
# ls -la /tsmdata/filepool
-rw------- 1 root tsm 2147483648 Jun 05 18:22 12345678.bfs
The above output shows that file volume /tsmdata/filepool/12345678.bfs is owned by root. Since the server instance is started with the instance userid (tsminst1), it does not have access to the file.
Resolving The Problem
Logon with the root userid and modify the ownership and permissions of the file volume(s) such that instance userid is authorized to access the file. For example, with the instance userid being tsminst1, the user group being tsmsrvrs, and the file volume being /tsmdata/filepool/12345678.bfs, use the below steps.
- Stop the Tivoli Storage Manager server instance.
- Modify the file volume(s) ownership and permissions. For example :
# chown tsminst1:tsmsrvrs /tsmdata/filepool/12345678.bfs
# chmod 600 /tsmdata/filepool/12345678.bfs
- Start the server with the instance userid.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21644723