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VTL volume not automatically relabeled

Troubleshooting


Problem

A VTL library is defined with the RELABELSCRATCH=YES parameter on a Tivoli Storage Manager server instance. A scratch volume is deleted from the storage pool but is not automatically relabeled leading to discrepancies in library inventory.

Symptom

The server activity log shows the following :

ANR1341I Scratch volume V01234L3 has been deleted from storage pool VTLPOOL.
ANR0984I Process n for RELABEL started in the BACKGROUND at timestamp.
ANR8799I RELABEL: Operation for library VTLLIB started as process n.
ANR8801I LABEL LIBVOLUME process n for library VTLLIB completed; 0 volume(s) labeled, 0 volume(s) checked-in.
ANR0985I Process 5 for RELABEL running in the BACKGROUND completed with completion state SUCCESS at timestamp.

It is possible for a volume to be scratch and no relabel process being launched. For example :

ANR1341I Scratch volume V56789L3 has been deleted from storage pool VTLPOOL.

Cause

Problem with VTL tape library and/or VTL tape drives

Diagnosing The Problem

Review the server activity log for library and tape drive related errors. For example :

ANR8758W The number of online drives in the VTL library VTLLIB does not match the number of online drive paths for source TSM.
...
ANR8840E Unable to open device <device> with error number 78 and PVRRC 2839.
...
ANR8311E An I/O error occurred while accessing drive VTLDRV1 (devicename) for OFFL operation, errno = 16, rc = 1.
...
ANR8779E Unable to open drive <devicename>, error number= 5.

Then, review the activity log to determine if server was restarted after the volume was scratched.

The RELABELSCRATCH=YES option enables the server to overwrite the label for any volume that is deleted and to return the volume to scratch status in the library. During this operation, volumes are checked out of the library and then checked back in with an immediate LABEL LIBVOLUME command.
If any RELABEL operation cannot obtain a drive or fails to relabel a volume for any reason, Tivoli Storage Manager will retry to relabel the volume on each future RELABEL attempt until a RELABEL operation is successful.
It is important to note that the list of volumes that were not successfully relabeled is kept in memory. This list is cleared when the Tivoli Storage Manager server instance is stopped and restarted. Therefore, on a server restart, the server will not relabel volumes that were not automatically relabeled prior to the restart.
In this case, the Tivoli Storage Manager server instance was stopped and restarted before the server had a chance to relabel the volume on a subsequent attempt.

Resolving The Problem

Determine the list of volumes that have been scratched and are no longer checked in with the Tivoli Storage Manager server. You can use the following administrative commands :

  1. Audit the library inventory with the following command :
    audit library <libname> checkl=barcode
  2. Verify the list of tapes currently in the library with the following command :
    show slots <libname>
  3. Verify the list of tapes currently checked in with Tivoli Storage Manager with the following command :
    query libv <libname>
  4. Compare the outputs between step 2 and step 3 and relabel the scratch tapes that are not checked in with the label libvolume command. For example :
    label libvolume <libname> search=yes labels=barcode checkin=scratch vollist=xxx overwrite=yes

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Document Information

Modified date:
17 June 2018

UID

swg21644622