IBM Support

TM1 API Using Excel to open a worksheet with included VBA API gives a Systemservercamsecurity required error

Technote (FAQ)


Question

What is the reason for this error ?

Cause

A IBM Cognos Server secured with CAM Authentication and using a TM1 Server with the same, can no longer use VBA code for TM1 in the Excel Spreadsheet, without having made a connection to the TM1 Server via Perspectives and the IBM Cognos server at the same time.

Answer

The main reason for this is that the TM1 Perspectives API is a Add-In for Excel , and its internal code does not have the methods , nor can make a CAM Connection to the IBM Cognos Server.

An Enhancement Request has been put forward to change the VBA API in Perspectives so that any CAM connection can be made.

Document information

More support for: Cognos TM1
TM1 API

Software version: 9.0, 9.1, 9.2, 9.3, 9.4, 9.5, 9.5.1, 9.5.2, 9.4 MR1, 10.1.0, 10.1.1, 10.2

Operating system(s): Windows

Software edition: Edition Independent

Reference #: 1644577

Modified date: 26 December 2013


Translate this page: