IBM Support

Unable to Delete or Edit saved QBR

Troubleshooting


Problem

Some applications provide Create QBR functionality but fail to give the user the ability to Edit or Delete that saved QBR - even if it was saved as non-public.

Symptom

The Run Reports dialog shows the saved QBR reports but the Edit and Delete buttons are not present

Cause

No sigoption exists for the 2 values that are required for this functionality (DELETEREPT and EDITREPT)

note: Editing of saved QBRs was added in Maximo 7.5, therefore the EDITREPT sigoption does not apply to Maximo 7.1. Delete and the corresponding sigoption DELETEREPT is available in 7.1 and later.

Resolving The Problem

-> Go to Application Designer
-> Find your application, in my case AMCREWT
-> Select Action - Add/Modify Signature Options
-> Add new rows for "EDITREPT" and "DELETEREPT"



-> Save
-> GoTo/Security/Security Groups
-> Select the EVERYONE group
-> Applications tab, filter for your application (mine is called "Crew
Types')
-> Grant Access to "Edit QBR Report" and "Delete Report Button"



-> Save
-> Log out
-> Log back in and the options should now exist for this application

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"BIRT","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.5;7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21644411