IBM Support

ANR7805E Volume <raw_logical_volume_name> is in use by another server

Troubleshooting


Problem

A Tivoli Storage Manager server instance is modified to run with the instance user ID instead of the root user ID. When the server is started, the ANR7805E error is logged.

Symptom

The server activity log shows the following messages :

ANR7805E Volume /dev/rlv_tsmvol1 is in use by another server.
ANR1311E Vary-on failed for disk volume /dev/rlv_tsmvol1 - unable to access disk device.

Cause

Temporary lock files that are owned by root exist in the /tmp directory.

Diagnosing The Problem

To prevent concurrent RAW volume access by more than one server, files are created in the /tmp directory to 'lock' these volumes. The names of these temporary files follow this pattern:
/tmp/adsm.disk.dev.<volumename>
where <volumename> is the name of the RAW volume defined in the /dev directory.
Examine the /tmp files to determine if lock files exist. For example :

# ls -la /tmp/adsm.disk.dev.*
-rw-r--r-- 1 root system 16 Jul 17 07:08 /tmp/adsm.disk.dev.rlv_tsmvol1

Resolving The Problem

Use the AIX 'ps -e' command to determine if other dsmserv processes from other server instances are running on the same machine. You can remove the temporary lock files and attempt to re-start the server only if no other dsmserv processes are running.

  1. Stop the Tivoli Storage Manager server instance.
  2. Remove the lock files. For example :
    rm /tmp/adsm.disk.dev.rlv_tsmvol1
  3. Restart the Tivoli Storage Manager server instance.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21644127