Report 'Separation by Action Reason' has no action reason

Technote (troubleshooting)


Problem(Abstract)

When running 'Separation by Action Reason' under Global Turnover, the report returns no data. Reviewing the generated SQL shows that part of the where clause is eliminating all reason codes.

Symptom

Report is empty when data is expected


Cause

In Adaptive Warehouse (AW), there is no join path defined between the fact and dimension (Assignment Action Monthly and Action Reason Type) used in the report. Because of this, the N/A filter (not applicable) from the dimension is being applied. This eliminates all action reasons.

Environment

Workforce Performance (default content)
Oracle Financial content

Diagnosing the problem

To diagnose the problem, run the report that is returning no data. If the where clause has some code that has <dimension attribute> = 'Not Applicable' or similar, check the join paths in AW for the fact that is being reported on.

Resolving the problem

To resolve the problem. in AW, change the Join path from 'Unrelated - use N/A' to 'Unrelated - use windowed aggregate'. Republish the target package and run a 'Refresh from Target package' in Adaptive Analytics before rerunning the report

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Document information


More support for:

Cognos Analytic Applications
Cognos 8 Workforce Performance

Software version:

10.1

Operating system(s):

Windows

Software edition:

All Editions

Reference #:

1644053

Modified date:

2013-07-16

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