OpenPages Reporting Framework Is Not Using the Correct Prefixes for Custom Object Types

Technote (troubleshooting)


Problem(Abstract)

An OpenPages environment recently had custom first class object types delivered, however the query subjects are not using the correct two letter prefixes in the reporting framework.

Symptom

The OpenPages Cognos reporting framework is NOT using the correct two letter prefixes for newly developed custom object types.


Cause

The custom object type names contain invalid characters.

Resolving the problem

To resolve the issue, the custom object types need to be renamed so there are no spaces and have no special characters. The resolve the issue, an administrator should:

    1. Stop the OpenPages services.
    2. Run the following PL/SQL where you replace <old-object-type-name> and <new-object-type-name> with the appropriate values
      BEGIN
        UTIL_OP50_UTILITIES.RENAME_OBJECT_TYPE('<old-object-type-name>', '<new-object-type-name>');
      END:
      /
    3. Save / commit the changes to the database.
    4. Start the OpenPages services.
    5. Open a supported browser.
    6. Go to the OpenPages URL.
    7. Login with an administrator id.
    8. Using the navigation menubar, go to: Administration -> Settings.
    9. Traverse to: / | OpenPages | Platform | Reporting Framework V6 | Configuration.
    10. Update the 'Object Prefix' setting with the new name.
    11. Enable System Admin Mode (SAM).
    12. Regenerate the reporting schema.
    13. Disable SAM.
    14. Regenerate the reporting framework.

Related information

OpenPages V6 Framework does not show correct 2-letter i

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

OpenPages GRC Platform

Software version:

6.0, 6.0.1, 6.1, 6.2, 6.2.1

Operating system(s):

Platform Independent

Reference #:

1643608

Modified date:

2013-07-11

Translate my page

Machine Translation

Content navigation