IBM Support

SAP RPT script fails to run when executed from schedule

Troubleshooting


Problem

Attempts to execute a SAP recorded test script from an IBM Rational Performance Tester (RPT) schedule fails with errors like:
  • "Error : Runtime error - MESSAGE_TYPE_X " displayed from Execution Event Console window
  • "SAP session not started" error
The script executes successfully if run standalone.

Cause

The Rational Performance Tester agent was started as a service instead of as a process. By default, the agent is started as a service with name "Majordomo" when the RPT agent is installed and runs on startup.

Resolving The Problem

The Majordomo service should be stopped and the RPT agent should be started as a process as follows:
  1. Stop the agent service by using Windows Task Manager.
    Find the Majordomo service in the Services tab of Task Manager and stop it.
  2. In the Task Manager Services tab, click Open Services and find the Majordomo service. Double-click it and change Startup type to Manual.
  3. Browse to the RPT agent's installation directory and navigate into the Majordomo directory.
    For example: C:\Program Files\IBM\SDP\Majordomo
  4. Start the agent as a process by launching Majordomo.bat from Windows Explorer or running it from the command line.
  5. Check that the Majordomo process is started successfully.
Now that the agent is running as a process, the RPT schedule will execute successfully.

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMMM5","label":"IBM Rational Performance Tester"},"ARM Category":[{"code":"a8m0z000000bp5aAAA","label":"Performance Tester-\u003EIntegrations-\u003ESAP"}],"ARM Case Number":"TS007534631","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]

Document Information

Modified date:
27 December 2021

UID

swg21643460