Troubleshooting
Problem
A Cognos BI Server installation experiences outage, showing an error: java.lang.OutOfMemoryError: PermGen space This error can be displayed to users via Cognos Connection or appear in log files.
Cause
The allocated Permanent Generation space is insufficient for the running application. The Permanent Generation is used for class definitions and any associated metadata. Insufficient space in this area may cause unexpected product failures.
Environment
Any Operating System
Oracle Java
Resolving The Problem
Update bootstrap_<platform>.xml and bootstrap_wlp_<platform>.xml
In the instructions below, an example file name is given (bootstrap_linuxi38664.xml). This file name varies by Operating System in the [cognos_install]/bin or [cognos_install]/bin64 directory.
Substitute the correct Operating System in the files name for the bootstrap_<platform>.xml and bootstrap_wlp_<platform>.xml
**To resolve the issue, for a 64-bit IBM Cognos BI installation, follow these steps:
- Navigate to the [cognos_install]/bin64 directory**
- Copy the bootstrap_linuxi38664.xml file to bootstrap_linuxi38664.xml.bak
- Modify the bootstrap_linuxi38664.xml in a text editor.
- Identify the line, which contains: -XX: MaxPermSize=128 m
- Alter this line to read: -XX: MaxPermSize=192 m
- Restart IBM Cognos Business Intelligence
- Monitor the system. If the error occurs again, follow steps 3 - 6 again, modifying the value to 256 m instead of 192 m.
**: For 32-bit installations of IBM Cognos BI, instead navigate to [cognos_install]/bin.
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21643252